Performance Upgrade appears to have broken Zapier Integration

Hi Brad,

Does Make use webhooks for it’s “search” and/or “find” methods?
Did your connections between Make - knack work without error these last few days?

@KnackSupport,
The work-around we used is failing intermittently in our zapier-knack connection, it seems that if we use an auto-increment field as an “internal object ID” the data is not able to be read.

Regards
Pablo

Hi Pablo

We’re still porting our Zapier integrations over to Make, but the ones we have completed are (so far) working without issue. The updates also run significantly faster.

When you create a webhook in Make, you have the following options for knack event:

  • Record created
  • Record updated
  • Record deleted

This will just pass the Record ID, which you use then need to “Get a Record” and retrieve the Data.

When you create the Make Scenario, you have the following options for Knack:
Triggers:

  • New Event
  • Watch Records

Actions:

  • Create a Record
  • Delete a Record
  • Get a Record
  • Update a Record
  • Upload a File
  • Make an API Call

Searches:

  • Search for a Record

Cheers
Adrian

As mentioned above by @AdrianBell27622
Make modules allow webhooks shown below.
In Zapier you can also fire a webhook on a form submission.
You can achieve the same result in Knack by sending a mailhook to Make.
This gives even more scope and flexibility as it can start a scenario on a form submit for a new record, or a record edit, even and action link.
Anywhere you can send an email in Knack you can start a Make scenario. :rocket:

When you create a webhook in Make, you have the following options for knack event:

  • Record created
  • Record updated
  • Record deleted

Mailhooks - Knack Database

Get a Record - Integromat

Our Knack - Zapier - Textmagic integration also stopped working with the upgrade August 9. We have 6 Zaps that run with a variety of filters. 4 of them continued to work fine and are still working fine. Those 4 looked for new records and then sent text messages to affected parties. The other 2 looked for updated records and previously sent text messages to affected parties. The updated records do not come across completely after the upgrade and therefor the filters don’t work and the zaps stop. I tried some work arounds and even rebuilt a test zap but nothing would come across.

I contacted both Knack and Zapier after I dug into the issue. Zapier replied quickly and let me know they had seen similar behavior. Knack took 5 business days (we are on a Pro Plan) to respond and let me know they were backed up due to issues from the upgrade and would let me know when they found something.

Obviously we are disappointed so I clicked around and found this entry. So today I carved out some time and created a couple Make Scenarios to replicate the Zaps that aren’t working. So far so good, and the tips on this thread helped immensely.

Thank you all for your insights and if I can provide any help, please drop me a line.

Scott

2 Likes

Its unbelievable that Knack is that irresponsible that they would destroy the integration with no concern at all. I have multiple apps using 30 plus Zaps tied to update a record. These are apps that I have over 1500 customers using them. I did see the work around but still unbelievable. Not professional at all.

1 Like

To whom it may concern,
@Brandon @Bill @KnackSupport

This issue is affecting large swaths of your userbase causing irreparable damage in some applications / use cases.

The time, capital, and resources being spent by your customers including myself is beyond understanding considering the high fees some of us are subscribed to.

I’ve had no response from the @KnackSupport team since tuesday and have written almost every day requesting a status on the fix.

Do tell us IF this issue will be solved, and if so, WHEN. This way we can take the appropiate measures and not be left holding the bag.

Kind regards
Pablo

2 Likes

It so irresponsible and unacceptable that they did this and then to not even respond is so wrong.

Hi Pablo,
I wrote back to your ticket, but I wanted to apologize here too for the radio silence on this one.

As a just in general update to this issue, so everyone is on the same page, we had a fix that we were set to deploy last week for this and it needed further work, it’s the top known issue and should be complete soon, as soon as we deploy a fix we’ll make sure that the relevant page is updated, and if I’m on at the time I’ll update this thread as well.

We released a fix for the Zapier issues this afternoon. If you still run into problems with them please make sure to submit a ticket to support@knack.com but feel free to tag me here as well so we can get those tickets as fast as possible.

3 Likes

It didnt work several fields still not sending data to Zapier.

@Bill Many of the fields still no longer get sent to Zapier.

Apologies Tim,
we’ve got people on this one, but any extra data that you can provide in an email to support@knack.com (unless you have, if you have can you give me the ticket number or DM me your e-mail so I can search for it) and I will make sure it gets added to the current ticket to help get it resolved asap. The information we’re looking for is:

  1. Zapier setup screenshots - As thorough as you can provide
  2. Result of the Zap
  3. View that is used in the Zap trigger or action - a link to this would be great
  4. History of the execution of the Zap (This can be retrieved from Zapier.)
  5. Any errors you see

Thank you for pinging to bring it to my attention, I’m dipping into having a more active role in the forums and I did not even see the notification that there was a ping. Sorry that it caused a delay in getting back to you for more of this information.

Hi Adrian, we have had the same issue since the performance upgrade. We had an app that has worked for years and now is unusable. Its frustrating to say the least when you have put so much time in and your whole bussiness is running on it.

Hi Dean,
Same as with Tim above, it would be very helpful if you can send the following to support@knack.com and then post here and ping me with the ticket number you receive so I can make sure it is included.

  1. Zapier setup screenshots - As thorough as you can provide
  2. Result of the Zap
  3. View that is used in the Zap trigger or action - a link to this would be great
  4. History of the execution of the Zap (This can be retrieved from Zapier.)
  5. Any errors you see

Hi Bill there are tickets in the system already. We have text formulas with null right throughout the app some of which we use as lookup fields which broken a lot of the things that have been set up. We have filters that are not working both at the front end and at the back end. We have record rules that are now not working. We have basic reports that no longer render on a page or have had to be removed because the page wasnt loading just to name a few all of which have worked fine for years but were broken as soon as the performance upgrade was done. Seeing some of the posts here and seeing that users that had performance upgrades done up to 8 weeks before ours and were having some of the same problems back then makes me scratch my head as to why it still pushed through with other users prior to fixing the problems.

Hi Dean, would you mind sharing the numbers of the tickets you’ve opened with us so that we could follow up on those and see where we’re at in regard to resolving the issues?

Hi Marek,

#161244
#161197
#161464

Last contact i had was a week ago and its been radio silence since. Its absolutely piss poor service, reading these forums and seeing that other people have been facing similar issues after their performance upgrade and yet 5 weeks later they still press on without with known problems and cause more customers to face those same issues is shithouse.

Thanks for those Dean. I’ve sent you a DM with more details about those specific tickets. I understand how you feel and am sorry that this has happened.

1 Like

Hi,

@Bill and the Knack team have informed us of a recent change last week that has resulted in our integration working again with success.

We’ve tested this throughout various zaps and apps and have found that the “updated record trigger” and its results are now working as expected.

I hope this aids other users that have been affected.

Kind regards,
Pablo

1 Like