Zapier not triggering on Knack Update Record form

I have a Knack App built that allows people to update records once they have been approved to do so. The form they work with shows them the current data we have on file and they can then update it. I then want to pass that data to Salesforce once they submit the form. I’m running into a couple of problems:

  1. I can’t get a test trigger in Zapier to find a test record on the form submission.
  2. Because of that I switched to the “when a record is updated” trigger instead, but it is still not finding the updated records. It found a different test record that I hadn’t edited though.
  3. Even on the incorrect test record, not all of the fields are coming over into Zapier for me to map. For example, I have multiple address fields on the updated record… 2 of them are coming over and one is not. I have several email fields on the updated record… 1 of them came over and one did not.

I’ve tried reconnecting my app in the Zapier connection settings in case there was something wrong there, but it still gave me the same results. I waited overnight in case the changes I made in Knack hadn’t “Indexed” or something even though it is supposed to be an “Instant” integration, but that didn’t do anything either. Anyone else run into this before? I see everything in my Salesforce Action steps. It just seems to be a problem with the Knack trigger step.

Hi @Matthew3 - this thread seems to be covering the same issue. If you’re not too far down the road with Zapier it may be worth looking at Make. I haven’t had any issues with missing data for mapping.

Thanks for jumping in on that one Carl!

We’re definitely in the thick of this issue currently and an engineer is involved and investigating universally. If you’d like to submit a ticket, we need the following information from you:

  1. Zapier setup screenshots - As thorough as you can provide
  2. Result of the Zap
  3. View that is used in the Zap trigger or action - a link to this would be great
  4. History of the execution of the Zap (This can be retrieved from Zapier.)
  5. Any errors you see

Go ahead and send all that to support@knack.com and we can follow up there.

2 Likes

Thanks @Bill. It’s a bit hard to share the information requested because I never got the zap fully setup because I couldn’t even get a test record to trigger. It seems like it is part of the universal issue and I’ll await the fix.

Thanks @CarlHolmes!

Give it a shot today!
We released another fix last night based on multiple collaborated reports and the hope is that it resolves all of these, but if not, we’ll need new ticket submissions with the full information above.

1 Like