Issues with Sums, Counts, etc

Is anyone else having ussues summing records, or using the count field?

When I check the status all systems say everything is working fine but all of my apps are just showing a blank when I try to add a new count or sum field. I have even tried waiting several days and updating the existing records but nothing happens.

1 Like

Not experienced this behaviour.
Recommend reporting to support but expect extended wait time for reply currently.

Same situation. Already reported. Old count fields are not working properly.
I have added a new count field (just to check) and it works fine.
Any suggestion?

Oh wow, my new ones aren’t working and my old ones are. Thank you!

I sometimes force the Sums and Counts to calculate by updating a dummy field in every record. Have also requested that there be an option that forces a recalculation of every field in every object (overnight).

Yes I do that also, thanks.

I guess the problem is actually my confusion as to the connections. I was trying to count a total of something but that something evidently has to be connected to the records.

I don’t know how anyone else does that sort of thing, for example count all records that meet a criteria. The pivot table seems to produce this result easily but it’s not the prettiest thing to look at when I just want to place a card on the dashboard.

Sum is also not working for me after the Knack upgrade last month.

1 Like

I’m experiencing the same issue. Sometimes creating a new count field with the same filters work, sometimes it doesn’t work as well. Tried updating the dummy field as well. Still having this issue.

Replying to add that I have also had bugs with filtered SUMs in recent weeks.
Reached out to support 1 week ago and still awaiting reply.

1 Like

me to

1 Like

I have messaged @Bill at Knack support to review your post. :+1:

2 Likes

thanks!

Please reply here with the ticket number you got for writing in (or let me know if it is a chat by DMing me your email address) and I will make sure that these get grabbed tomorrow. There have been a larger number of these happening recently and we’ll need to look into them.

This is my request around the same issue. request (#160106)

Hi Bill,

My ticket number is #161304, and still awaiting progress from the “technical support team”.

Still with them. They’re an escalated level and working the issue. You’ll continue to get followups in that thread.

Going to need to follow up with you in that ticket on this one.

I have found that there is sometimes a significant delay in when the calculated fields based on connected records updating. I have seen it take as much as 4-5 hours for a calculated field update (if I created the calculated field AFTER the records were created). Furthermore, I doesn’t seem like the trick of using an “Update” field to bulk update records seems to aid in this process.

Are you seeing the update not happen at all (like if you come back the next day they still aren’t updated)?