How to force formula fields to evaluate/update? (records created by Make/Integromat)

Hi,

It seems that equations don’t evaluate until the record is touched/changed, which I suppose is to be expected?

Here is my issue:
I am making extensive use of Make (Integromat) for things like duplicating/copying child & grandchild records (I love it by the way, very powerful and easy to set up).

One of the records that are created are on a table with a field that is a simple addition formula of some other fields.

However when Make (Integromat) creates a child or its grandchild records, none of the formulas in that record are evaluating, so for examples totals are just showing as blank. Even refreshing the page does not update them.

I am guessing a simple update button will fix the issue (eg it would just update a utility date/time field on the record with the current date).

Before I did that I was wondering if anyone else has this issue, and if so how they get around it?

Thanks!

That shouldn’t be the case. I have over 100 active scenarios and many have text formula or equation fields which update when Make creates the child record. :man_shrugging:
Personally, I find it difficult to trouble shoot without seeing what’s you’ve built and walking through it. If you want to connect send me a DM and I’ll see if I can throw any light on it.

1 Like

Hi @CarlHolmes :+1: thank you so much for the fast reply and for offering to take a look . Just knowing that this should work motivated me to revisit the Scenario. :smile:
At the end of this scenario is the Make grandchild ‘create a record’ and Knack still does not evaluate the equation fields in the newly created record, HOWEVER, I have solved the issue by adding another step “Update a record” at the end, and I just write something to a blank text field on each record ! Yay, when that step is hit, the equation fields the newly created records all calculate!
Thanks again! :grin:
Calvin.

I think the issue might be related to the order of the fields in object. Make sure that the connection field is above the equation.

1 Like

Hi @MartinD, and thanks for your reply. Yes I see what you are saying re order of the objects - something to bear in mind in future.

I should have clarified that that on a page, with both parent and connected records, updating the connected
records works perfectly (as in the connected record equations and the parent record equations evaluate and update) no issues.

For me its just when Make creates a record none of the formulas in that record are evaluating, e.g. totals are just showing as blank, and as they are formulas they are not on the actual Make step anyway.

I did try changing the order of the fields in the schema (connection above equations), still no better, as in the equations don’t evaluate in the record written by Make.

As mentioned above though, I do have a simple solution and that is to add the additional step to the Make sequence… “Update a record” , and I just write something to a blank text field on each record! Formulas on that record evaluate - everything works!

I suppose humbleness and being a relative beginner at Knack prevents me from marking my own post above as the solution! Haha

1 Like