Performance Upgrade - creating 'internal server errors' in Make integration

We went through the Performance Upgrade last Thursday - and now keep hitting errors in our Make integrations when writing to a table:


Internal Server Error

We can’t identify the pattern, and retrying the Incomplete Execution in Make just returns the same error. Has anyone encountered this and found a cause?

1 Like

Getting the same after app was upgraded. Only one module though. Were you able to resolve this?

Unlikely this is related but we saw the same “500 Internal Server Error” with a chart and discovered after some testing it was related to a field with an underscore _ in its name.

Removing that fixed the issue without any further testing.

We’re having the same issue as Vaughan and Amaan.

We have numerous integrations that worked just fine for the past few years, till a few weeks ago, a lot of them are broken - the same payload that went through as a successful POST now fails with a 500 “Internal Server Error”.

We think this is directly linked with problems with the upgrade to the Knack API.

We eventually solved this - there was a mapped field where I was using the incorrect lookup. So when it tried to write to Knack from Make, Knack couldn’t resolve the lookup - and threw the 500 error.

I assume that before the upgrade, Knack was ignoring those issues and just leaving the field blank.

So I would suggest you look through each mapped field to make 100% sure that this is mapping correctly.

Hi Vaughan,

Thanks for that, but we have thoroughly inspected our case with Knack.

They told us the reason why records aren’t being posted is because the connection field we were trying to populate with a record id - that record did not exist.

On a closer look we found that this was not the case at all, and that record definitely exists.

There is something that is drastically wrong, because it’s affecting so many integrations of ours and the payloads fail consistently to the point where not a single one will succeed.

We haven’t been answered yet and are still waiting to hear back.

Hi there, sorry to hear that you haven’t received a follow-up response yet.

Could you please send us the number of the ticket that you’ve submitted, and we’ll follow up on the matter in the ticket itself?

We’ve got 38 active Make scenarios that connect with Knack in some way and haven’t seen an error yet since the upgrade. Keen to hear what you uncover @3PM in due course.