How to stop table scrolling?

I have a table in a modal popup page, but it is limiting the table height, which means you then need to scroll to view the entire table. Seems very random - if I add a new table, sometime this happens and sometimes it doesn’t.
Does anyone have a way to force this not to happen?
I found this code in the community pages, but it doesn’t seem to work.

.kn-table-wrapper {
overflow: visible;
}

.kn-table-wrapper.is-constrained {
max-height: 100%;
}

Hi Craig,

That code is correct, so if it’s not working, there might be some conflicting CSS elsewhere. You can try adding the word !important to override the conflicting CSS if any exists.

The updated code would look like this:

.kn-table-wrapper {
overflow: visible!important;
}

.kn-table-wrapper.is-constrained {
max-height: 100%!important;
}

I’ve tested the above and it works. If you find that it still isn’t working, you can try confirming that your CSS doesn’t have invalid comments in it. The syntax for comments in CSS should be like this:
/* this is a comment */

I often see people using this syntax in CSS which is for JS not CSS, and can break your CSS:
// this is a comment

Hope this helps.

Thanks for that info!
I think this issue is a bug in the builder as it only seems to happen when I create a view and move its position on the page.
I’ve worked out that if I create the views in the correct order they need to be on the page and don’t move them, then the issue doesn’t occur. Difficult to repeat the bug exactly every time, but I’ve found that workaround anyway.

(The builder seems quite buggy to me at present - various issues with views not sticking, and also views deleting at times also).

I find that if you’re copying views between pages, quite often the view appears to have copied and is visible in the builder, but doesn’t appear in the live app. I then refresh the builder page and the view isn’t there so didn’t copy.

It’s very difficult to consistently repeat so I’ve never been able to report. Sometimes I’ve had to redo the copy several times before it’s “stuck”.

I’ve also found that components on page views in the builder sometimes move around or return to a previous position after being moved.

1 Like

Yes, I agree with all that Carl.

@CarlHolmes I’ve had the same issue with page views that I’ve moved in the builder returning to a previous position. It seems to me that it’s basically not saving the changes. For example, if you have a table view and you move a column, it will prompt you to save the changes if you try to leave that view. However, if you rearranged the views on a page it won’t give you that same prompt. A trick I’ve been using when I move a view is to also do something that prompts me to save the changes. Something like changing the view title by deleting and reentering the last character in the title. You don’t actually change it, but the builder thinks you did so it prompts you to save the changes. This save will get the new view arrangements to stick. Seems like this shouldn’t be necessary but, say la vie.

2 Likes

@John_Prescriptive.Solutions - good workaround to force a save :+1:
I have often wondered why there isn’t a save option when you have moved components on a view.

I’ve also had a couple of other bugs that are equally difficult to replicate.

The table is set to not allow filters but the filter button suddenly reappears? You have to toggle the filter options in the builder to show filters, Save, then toggle back and Save to resolve
.
I’ve also had similar on connected fields in drop down boxes not being sorted A-Z even though it is setup that way. You have to toggle to Z-A, Save, then toggle back to A-Z and Save to resolve.

Just some of the odd quirks of using the builder sometimes.
Very difficult to replicate, infrequent and random :laughing: