Field Disappears

Looking to see if anyone has ever had this issue...there seems to be 3 issues occurring with disappearing fields:

1)  I was editing a form when a field stopped displaying in the live application.  I returned to the editor and and the field disappeared.  I attempted to delete the field from the form page and re add the field.  The field is now not displayed in the Inputs-Fields list.  

2) I copied the application, then tried the new beta editor.  In the editor the form displays with no fields, but all the fields in the Inputs-Fields list appear to be added to the form ....I just can't see them in the editor.  If I add a field to the form that wasn't previously on the form, magically, all the fields that are supposed to be displayed appear.

3)  So at this point I think I have solved the issue in point 1, except now when I return to the live application and attempt to edit the field mentioned in point 1, it simply disappears and does not hold the edit.  I can reload the page and it reappers, but will not edit.

I have dried correcting the issue on different computers and clearing the cache in my browser.  I have had similar issues with fields not displaying in the Inputs-Fields section before, but they were simple fields that I could easily delete and recreate.  This time the field in question has many conditional rules and display rules throughout many pages and will take considerable time to replicate.  This seems like a fairly significant application issue.

I found this other post that is similar but not identical:

Anyone else experience this issue and if so was there an easy solution other than recreating the field?