Cannot import any CSV file, no matter how simple

I can’t seem to import ANY CSV file to update existing records.

I have just tried a simple CSV file with two fields “Barcode” and “Bin Location”, 64 lines.

All the Barcodes (unique field) already exist, all the Bin Locations already exist. I simply want to import the CSV to update the Bin Locations for the given Barcodes, here are the first few lines -

Barcode,Bin Location

etc etc.

My CSV file is UTF-8, no issues. No extraneous spaces, extra dots, leading zeros etc.

This, and literally every other CSV import, now just fail on record 1 - has been like this for a few weeks. The reason for the failure is never shown, which would be a real help!

I am resigned to updating records via the API which is time consuming for this small task, and near on impossible for a large import with hundreds of stock records and dozens of columns.

Why has CSV import stopped working?

I doubt it will help, but I found sometimes it works if csv is from googlesheets but not excel

1 Like

Hi, @VernonFox!

Sorry that you have been having trouble importing such a simple CSV file.

We recommend copying your data into a new Google Sheet and then exporting it to CSV file. This should get rid of any underlying formatting or encoding issues that may have been introduced to your file that can not be easily identified.

If creating the import file through Google Sheets doesn’t seem to fix the issue, then we are happy to help troubleshoot this for you! To get started we will need the following information:

  • A link to the table where you’re importing the file
  • A sample copy of the file you’re importing
  • The estimated date/time of the last time you tried the import

You can send the above information to or send us an in-app message. Thank you for sharing this, and I hope this tip helps. If not, we look forward to troubleshooting this for you!