Apps disappearing!

Hi All,

I have been working with the app for the last week, and signed up to the pro plan today for some upcoming work I need to do.

I built a separate app today, just for teaching myself really (but one that will be used). However, twice today the app has completely disappeared after about an hour of entering tables and fields etc.

The app is still there in my app list, but when I click on it, it says “app not found”. I have not changed any settings and have saved after every table and field.

This is quite worrying as it is causing me a lot of wasted time, and doesn’t give me a lot of confidence. I have used the forum search feature to see if this was an issue but can’t find anything that is exactly the same issue.

Any help appreciated.


Hi @chris.belcher - I’m aware we have already connected.

By chance, are you using the builder in two separate browser instances on the same or different screen, as this could result in some conflicts.

Be worth logging out of the dashboard, closing your browser tab and logging back in again.

In all the years I’ve been using Knack I’ve never experienced an app disappearing.


Hi Chris,

We’re sorry for the trouble this is causing you. This is not a usual bug that you will likely find discussions about in the forum. If you have already reached out to our support team and haven’t heard a response from our team, please share your ticket number here and I will ensure that this matter gets taken care of promptly.

If you haven’t already reached out to our support team, please do so by using the chat widget in the Builder or by submitting this form. They will be happy to help you get access to your app and investigate the cause of this issue to prevent this from happening to you and other users again in the future.

Again, we’re sorry for this inconvenience and we hope that the rest of your Knack experience going forward is positive.

Have a great week! :slight_smile:

1 Like

Thanks for the replies. The app is still showing on my app list with the correct name. However when I click the app to open it in the builder the second part url is untitled-app/app-not-found?slug=untitled-app

Just to confirm the only things I have done in the builder is build three tables, nothing else has been changed or edited.

I am going to try again this morning, but in the meantime if anyone has any ideas that would be appreciated.

Also, I have tried changing the URL to match the name of the app but it continues to load with the app not found URL

Just an update. I have now logged on and I can now view the app. When I click on it instead of the app not found url I now get untitled-app/schema/list

It’s strange it is still called an untitled app, even though it has been named?

Is there anything else I need to do?

Are you inputting a name for your app here in the App Settings section?:

Or, are you naming your app here?:

untitled-app/schema/list” is an expected URL if the name you’re inputting for the app isn’t saving.

Our support team will be able to look further into this internally outside of the forum and let you know what needs to be done in order for your app name input to save to your app, but for now I can suggest trying to save your app name in both sections, log out, log back in, and check the app again to see if the name saved.

You could also try to duplicating the app and naming the new app, however, this shouldn’t ever be a workaround any of our users need to do, so again, please don’t hesitate to reach out to our support team for help!

Sorry you’re having so much trouble, and I hope the rest of your Knack building goes smoothly!

Thanks for the reply Les. I was working on my Mac desktop with it all day today, and it has been working well.

Yes I had named the app as per your suggestion. I logged on to my laptop again today and clicked the app, this time the correct URL came up but it still said “app not found”

I tried logging out as suggested by Carl in the earlier post and even using different browsers, but that didn’t work. However, I have now restarted the laptop and logged in again and the app is there, so panic over! It really was quite concerning as I had thought I had messed up somewhere, but as Carl suggested earlier, perhaps it was a conflict.

Thanks both for your help, Knack is really good, and I am enjoying using it.