Record updated questions

I’m capturing date/time record is entered in a field EnteredWhen, using the field’s auto-entry option. That’s working fine. In another field, UpdatedWhen, I’m capturing when record is modified, using a record rule defined with the view on a page. They’re both working, but apparently they’re using ‘current date/time’ calculations in two different time zones!

EXAMPLE: It’s about half past noon here in San Antonio, Texas. I just created a record. EnteredWhen = 1/7/22 12:26PM. A couple of minutes later, I edited the record slightly and saved the edits. The UpdatedWhen field now says 1/7/22 1:29PM — clearly referencing the eastern time zone of the US rather than the Central time zone which is local for us in Texas. What’s up with this and how can I make them consistent?

And one other thing: I can’t capture updated date/time if I allow inline editing, right? That’s according to this page: “This capability only applies to forms, and is currently not available for changes made via inline editing on a table.” That’s too bad as it means I probably won’t be able to allow users to do inline editing, no matter how convenient it may be.

Hey @WilliamPorter - The date/time is driven from your app settings. I’m in the UL but just changed my test app to GMT -6 Central America.
I set the date added on the field as you have (I use this method). I then added another date/time field for updated. This is using a record rule on form submission. As the date/time is coming from the app settings it works as expected. You can’t dictate different time zones for date/time fields so something else is going on. :man_shrugging:

You can update the date/time field with inline editing, you’ll just have to add a record rule to each field. If you have every field on your table set to inline edit then this is going to be a chore to setup. If you have a modal popup to edit the record then you only need one record rule to update the date/time field when the form is submitted.

1 Like


I went into App Settings for the app. When I first went in, Time Zone was set to Eastern USA. Texas is in the Central USA time zone. Daylight Savings was set by default to +1 hour during Daylight Savings. I didn’t touch the Daylight Savings setting but did change the time zone to Central. Tested again, creating a record, waiting a minute or two and then editing it slightly, and now the times for EnteredWhen and UpdatedWhen are what I expected. I’m not sure WHY that fixed it. It looks like the CurrentTime value may be local — but that UpdatedDate was (earlier) being adjusted for time zone.

Anyway it’s working at the moment, for me here in Central Time. Wondering if it will keep working when I have users out in California (Pacific Time) accessing the database. Will revisit when that happens.

Thanks also for tip about capturing updated time when user edits table inline. Looks like that is a new capability and the article in the Knowledgebase needs to be updated. :slightly_smiling_face:

Thanks again!


1 Like

Hey @WilliamPorter - I have clients across the USA using Knack and don’t have any issues.
Glad that you’ve managed to resolve it.

If this covers your query please mark solved :+1:

The below article covers inline edit rules.