Getting "please wait 50 seconds" when my users click submit

I just launched an app and when my team clicks a submit button they are forced to wait 50 seconds before continuing. its present on multiple users, myself included, and from multiple computers. anyone have an idea?

this is what they get… it counts down

Hi @Irfan,

While I have no initial ideas on why this is occurring without investigating the issue, I will let our team know to keep an eye out for a report of this issue if you choose to reach out to our support team. Please don’t hesitate to submit a support ticket for this as our team would be happy to help you! You can do so by submitting this form here.

We hope to hear from you soon! :slight_smile:

Thanks. I filled that form out and also submitted a request through the builder

1 Like

@NormandDefayette_CortexRD would you be able to help? This form is the only one i have a problem with, and its only when i have the KTL Loaded. When I remove the loaders 5 lines, the problem goes away. Knack support sent me this screenshot:

i mainly want KTL to custom color fields app-wide.

thank you for the help

Edit : actually it’s affecting several forms. I’ve had to disable KTL in the meantime

I am investigating the issue now.
I need to know what you are clicking when this happens. Submit only?

Is it an Add or Edit form, or Inline Edit or all of these do the same thing?

Norm

Hi Les,

Please tell your engineers to forget about this. It’s the KTL and I am fixing this now.

I try to tell my users not to submit tickets to Knack support until they are 100% it’s not the KTL, but not everyone knows yet.

I’m doing my best to avoid that: Troubleshooting the KTL · cortexrd/Knack-Toolkit-Library · Discussion #186 (github.com)

Sorry for the trouble,
Norm

2 Likes

@Irfan,

Can you refresh your browser please and test KTL v0.23.3?

Also, go see this page please. It explains how to do a few tests to determine if the KTL is causing the issue or not. Troubleshooting the KTL · cortexrd/Knack-Toolkit-Library · Discussion #186 (github.com)

Let me know it the update solved your issue,
Norm

Thank you I will test it today! It’s only when clicking a form submit button (that we’ve noticed).

Sorry I didn’t think it was KTL because I never experienced it throughout testing on my own so I thought something happened on Knacks end after I uploaded 2500 records. I’ll double check it in the future.

Le me know as soon as possible please.
Norm

0.23.3 gives the same issue of waiting 50seconds. I’ll go thru the other steps soon

and yes when i disable KTL via the pop-up menu everything works as expected. same result as commenting out the code in the builder

Can you try latest fix in v0.23.5 please.
Norm

Looks like that did the trick! Thank you.

In the future with a KTL issue should in knack forums here and tag you or should I create a discussion on GitHub?

@Irfan,

Thanks, I’m very glad to read that.

Yes, the best place to report any issue with the KTL is definitely in the GitHub page.
This ensures that I’ll see your post quickly and so will others.

Norm

1 Like

Hi @NormandDefayette_CortexRD,

No worries! Our support team found that it was custom code causing the issue, so Irfan’s ticket never got to our engineers.

Thank you for swiftly looking into this!

1 Like