Hiding Table header

I’m trying to hide a table header using CSS, shold be simple but doenst work.

#view_351 thead { display:none;}

What am I doing wrong?

Hi Leigh

Not being a coder, this worked for me:

#view_979 thead {
display: none;
}

Dean

Thanks Dean, but its the same thing really - the extra lines are just window dressing.

But I tried it and it worked. WTF. Then I compressed it back onto 1 line, and it still worked.
So now I’m more confused than ever, but it works so I don’t care.

@LeighBerre96926

You could use KTL

_style=[display: none], [ktlTarget, $('#view_351 thead')]

Craig

1 Like

Thanks for the pointer, hadnt thought of that option.

No worries @LeighBerre96926. I find it easier & more helpful in the builder as you can see the keywords. If you hide the table header more than once I would create a class in the CSS and use KTL as well:

.hide-table-head thead {
      display: none;
}

Then you can add _cls to any grid view:

_cls=[hide-table-head]

A ready to use class that you can add to any table’s description to hide the table head.

Craig

Thank you for that information on how to combine CSS & KTL.